forum.wfido.ru  

Вернуться   forum.wfido.ru > Прочие эхи > RU.CISCO

Ответ
 
Опции темы Опции просмотра
  #41  
Старый 13.03.2018, 16:51
Eugene Grosbein
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Eugene Grosbein написал(а) к Anton Gorlov в Mar 18 19:28:51 по местному времени:

13 марта 2018, вторник, в 15:00 NOVT, Anton Gorlov написал(а):

AG> Так.. дошли теперь руки до динамического роутинга между циской и новым
AG> роутером.
AG> Застрял на анонсе роутов, котоыре по MBGP получил, с диагностикой на стенде,с
AG> циски
AG> ASW1_C6509(config-router)#neighbor 192.168.254.253
AG> % OSPF: Configured Nbr 192.168.254.253 is incompatible with OSPF network type
AG> on Vlan6
AG> Что я тут пропустил?
AG> router ospf 1
AG> router-id 192.168.254.254
AG> network 192.168.254.252 0.0.0.3 area 0
AG> neighbor 192.168.254.253

Тебе не нужно вообще указывать neighbor, они сами найдут друг друга,
если правильно указал network и не включал passive-interface для Vlan6.

Покажи ещё show run int Vlan6

Eugene
--
Choose no life
--- slrn/1.0.2 (FreeBSD)
Ответить с цитированием
  #42  
Старый 13.03.2018, 17:41
Anton Gorlov
Guest
 
Сообщений: n/a
По умолчанию MBGP, PIM and Co

Anton Gorlov написал(а) к Eugene Grosbein в Mar 18 16:21:46 по местному времени:

Привет Eugene!

Так..с соседями разобрался..спасибо Alexandr Kruglikov за помощь.
А вот заредистрибьютить то что получил по MBGP в ospf не получается..

То ест ьна цискевижу кучку роутов в
sh ip route multicast. А на 2 роутере только то что direct connected

===
SNR-S4550-24XQ-AC#sh ip route ospf
O E2 192.168.1.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.29.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.30.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.31.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.32.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.33.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
O E2 192.168.34.0/24 [110/20] via 192.168.254.254, Vlan6, 00:08:58 tag:0
===


Конфиг с циски

router ospf 1
router-id 192.168.254.254
redistribute connected
redistribute static
redistribute bgp 47618 metric-type 1 subnets
passive-interface default
no passive-interface Vlan6
network 192.168.254.252 0.0.0.3 area 0


С уважением. Anton aka Stalker

Linux Registered User #386476
[#TEAM:*#] [#Злой СисОп_#] [*Нeavy Metal!*] [*_Усачи]
--- GoldED+/LNX 1.1.5-b20160322
Ответить с цитированием
  #43  
Старый 13.03.2018, 18:11
Eugene Grosbein
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Eugene Grosbein написал(а) к Anton Gorlov в Mar 18 20:41:59 по местному времени:

13 марта 2018, вторник, в 16:21 NOVT, Anton Gorlov написал(а):

AG> Так..с соседями разобрался..спасибо Alexandr Kruglikov за помощь.
AG> А вот заредистрибьютить то что получил по MBGP в ospf не получается..

Мультикастные маршруты распространяются по PIM, а не по OSPF.

Eugene
--- slrn/1.0.2 (FreeBSD)
Ответить с цитированием
  #44  
Старый 13.03.2018, 18:41
Anton Gorlov
Guest
 
Сообщений: n/a
По умолчанию MBGP, PIM and Co

Anton Gorlov написал(а) к Eugene Grosbein в Mar 18 17:10:58 по местному времени:

Привет Eugene!

13 мар 18 года (а было тогда 20:41)
Eugene Grosbein в своем письме к Anton Gorlov писал:

AG>> Так..с соседями разобрался..спасибо Alexandr Kruglikov за помощь.
AG>> А вот заредистрибьютить то что получил по MBGP в ospf не
AG>> получается..
EG> Мультикастные маршруты распространяются по PIM, а не по OSPF.

Эм.. мне роуты до источников мультикста отдаёт апплинк и именно по MBGP.
Изменить это я не могу.

router bgp 47618
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 81.xx.240.105 remote-as xx148
!
address-family ipv4
neighbor 81.xx.240.105 activate
exit-address-family
!
address-family ipv4 multicast
neighbor 81.xx.240.105 activate
exit-address-family


sh ip route multicast
....
10.0.0.0/25 is subnetted, 1 subnets
B 10.1.254.0 [20/0] via 81.xx.240.105, 5w2d
...
93.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
B 93.100.195.2/32 [20/0] via 81.xx.240.105, 4w5d
B 93.100.195.3/32 [20/0] via 81.xx.240.105, 2w6d
B 93.100.195.4/32 [20/0] via 81.xx.240.105, 18:46:51
B 93.100.195.5/32 [20/0] via 81.xx.240.105, 6d09h
B 93.100.195.10/32 [20/0] via 81.xx.240.105, 4w0d





С уважением. Anton aka Stalker

Linux Registered User #386476
[#TEAM:*#] [#Злой СисОп_#] [*Нeavy Metal!*] [*_Усачи]
--- GoldED+/LNX 1.1.5-b20160322
Ответить с цитированием
  #45  
Старый 13.03.2018, 19:21
Eugene Grosbein
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Eugene Grosbein написал(а) к Anton Gorlov в Mar 18 21:55:23 по местному времени:

13 марта 2018, вторник, в 17:10 NOVT, Anton Gorlov написал(а):


AG>>> Так..с соседями разобрался..спасибо Alexandr Kruglikov за помощь.
AG>>> А вот заредистрибьютить то что получил по MBGP в ospf не
AG>>> получается..
EG>> Мультикастные маршруты распространяются по PIM, а не по OSPF.
AG> Эм.. мне роуты до источников мультикста отдаёт апплинк и именно по MBGP.
AG> Изменить это я не могу.

А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
но не нужно. Просто дальше по BGP их и отдавай.

Eugene
--
Устав от радостных пиров,
Не зная страхов и желаний
--- slrn/1.0.2 (FreeBSD)
Ответить с цитированием
  #46  
Старый 13.03.2018, 20:21
Alexandr Kruglikov
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Alexandr Kruglikov написал(а) к Eugene Grosbein в Mar 18 20:11:36 по местному времени:

Привет, Eugene!

13 мар 18 21:55, Eugene Grosbein писал(а) к Anton Gorlov:

EG> А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
EG> но не нужно. Просто дальше по BGP их и отдавай.

Я вообще не знаю, зачем он загнался с редистрибьюцией.
Возможно у SNR проблемы с mbgp?

З.Ы. (Замечу Ышо): я на стенде поигрался - не лезут из mbgp в ospf маршруты, хоть ты тресни. Обратно - пожалуйста...

С наилучшими пожеланиями, Alexandr.

--- "GoldED+/LNX 1.1.5-b20170303" ---
Ответить с цитированием
  #47  
Старый 13.03.2018, 21:01
Anton Gorlov
Guest
 
Сообщений: n/a
По умолчанию MBGP, PIM and Co

Anton Gorlov написал(а) к Eugene Grosbein в Mar 18 19:32:44 по местному времени:

Привет Eugene!

13 мар 18 года (а было тогда 21:55)
Eugene Grosbein в своем письме к Anton Gorlov писал:

EG> А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
EG> но не нужно. Просто дальше по BGP их и отдавай.

Ога про них.
То есть поднять до 2 роутера вместо OSPF такой же ТПЗ+address-family ipv4 multicast и фейковую AS на 2 роутере?


С уважением. Anton aka Stalker

Linux Registered User #386476
[#TEAM:*#] [#Злой СисОп_#] [*Нeavy Metal!*] [*_Усачи]
--- GoldED+/LNX 1.1.5-b20160322
Ответить с цитированием
  #48  
Старый 13.03.2018, 21:11
Eugene Grosbein
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Eugene Grosbein написал(а) к Alexandr Kruglikov в Mar 18 23:40:27 по местному времени:

13 марта 2018, вторник, в 20:11 NOVT, Alexandr Kruglikov написал(а):

EG>> А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
EG>> но не нужно. Просто дальше по BGP их и отдавай.
AK> Я вообще не знаю, зачем он загнался с редистрибьюцией.
AK> Возможно у SNR проблемы с mbgp?
AK> З.Ы. (Замечу Ышо): я на стенде поигрался - не лезут из mbgp в ospf маршруты,
AK> хоть ты тресни. Обратно - пожалуйста...

default-metric не забыл?

Eugene
--
Рейтинг, рейтинг - юбер аллес! (суровая правда телеискусства)
--- slrn/1.0.2 (FreeBSD)
Ответить с цитированием
  #49  
Старый 13.03.2018, 21:11
Anton Gorlov
Guest
 
Сообщений: n/a
По умолчанию MBGP, PIM and Co

Anton Gorlov написал(а) к Alexandr Kruglikov в Mar 18 19:48:22 по местному времени:

Привет Alexandr!

13 мар 18 года (а было тогда 20:11)
Alexandr Kruglikov в своем письме к Eugene Grosbein писал:

EG>> А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
EG>> но не нужно. Просто дальше по BGP их и отдавай.
AK> Я вообще не знаю, зачем он загнался с редистрибьюцией.
AK> Возможно у SNR проблемы с mbgp?

Эм.. да я даже хз.. почему с OSPF решимл ковыряться.
То есть поднять на 2 роутере так же BGP+address-family ipv4 multicast на фейковой AS?

AK> З.Ы. (Замечу Ышо): я на стенде поигрался - не лезут из mbgp в ospf
AK> маршруты, хоть ты тресни. Обратно - пожалуйста...




С уважением. Anton aka Stalker

Linux Registered User #386476
[#TEAM:*#] [#Злой СисОп_#] [*Нeavy Metal!*] [*_Усачи]
--- GoldED+/LNX 1.1.5-b20160322
Ответить с цитированием
  #50  
Старый 14.03.2018, 12:01
Alexandr Kruglikov
Guest
 
Сообщений: n/a
По умолчанию Re: MBGP, PIM and Co

Alexandr Kruglikov написал(а) к Anton Gorlov в Mar 18 11:52:46 по местному времени:

Привет, Anton!

* Ответ на сообщение из CarbonArea (Мыльце для меня).

13 мар 18 19:48, Anton Gorlov писал(а) к Alexandr Kruglikov:

EG>>> А, ты про маршруты до источника. Редистрибьютить их в OSPF можно,
EG>>> но не нужно. Просто дальше по BGP их и отдавай.
AK>> Я вообще не знаю, зачем он загнался с редистрибьюцией.
AK>> Возможно у SNR проблемы с mbgp?
AG> Эм.. да я даже хз.. почему с OSPF решимл ковыряться.

насколько я помню, я тебе сразу посоветовал либо городить статики, либо прокинуть дальше bgp, а не плодить зоопарк протоколов.

AG> То есть поднять на 2 роутере так же BGP+address-family ipv4 multicast
AG> на фейковой AS?

Почему на фейковой? Есть нормальный диапазон от 64512 до 65534 для локального использования.

С наилучшими пожеланиями, Alexandr.

--- "GoldED+/LNX 1.1.5-b20170303" ---
Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 21:23. Часовой пояс GMT +4.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc. Перевод: zCarot