forum.wfido.ru  

Вернуться   forum.wfido.ru > Прочие эхи > RU.UNIX.BSD

Ответ
 
Опции темы Опции просмотра
  #1  
Старый 09.01.2021, 17:35
Sergey Anohin
Guest
 
Сообщений: n/a
По умолчанию InnoDB+UFS+SSD

Sergey Anohin написал(а) к All в Jan 21 16:18:48 по местному времени:

Нello All
А скажите как в 21 веке тюнят сабж?
Нашел только это:

When using the InnoDB storage engine on Solaris 10 for x86_64 architecture (AMD
Opteron), it is important to use direct I/O for InnoDB-related files. Failure to
do so may cause degradation of InnoDB's speed and performance on this platform.
To use direct I/O for an entire UFS file system used for storing InnoDB-related
files, mount it with the forcedirectio option; see mount_ufs(1M). (The default on
Solaris 10/x86_64 is not to use this option.) Alternatively, as of MySQL 5.1.18
you can set innodbflush_method = ODIRECT if you do not want to affect the
entire file system. This causes InnoDB to call directio() instead of fcntl().
Нowever, setting innodbflush_method to ODIRECT causes InnoDB to use direct I/O
only for data files, not the log files.

When using the InnoDB storage engine with a large innodbbuffer_poolsize value
on any release of Solaris 2.6 and up and any platform (sparc/x86/x64/amd64), a
significant performance gain might be achieved by placing InnoDB data files and
log files on raw devices or on a separate direct I/O UFS file system using the
forcedirectio mount option as described earlier (it is necessary to use the mount
option rather than setting innodbflushmethod if you want direct I/O for the log
files). Users of the Veritas file system VxFS should use the convosync=direct
mount option. You are advised to perform tests with and without raw partitions or
direct I/O file systems to verify whether performance is improved on your system.

Other MySQL data files, such as those for MyISAM tables, should not be placed on
a direct I/O file system. Executables or libraries must not be placed on a direct
I/O file system.

If the Unix top tool or the Windows Task Manager shows that the CPU usage
percentage with your workload is less than 70%, your workload is probably
disk-bound. Maybe you are making too many transaction commits, or the buffer pool
is too small. Making the buffer pool bigger can help, but do not set it equal to
more than 80% of physical memory.

Bye, , 09 янваpя 21
--- FIPS/IP <build 01.14>
Ответить с цитированием
Ответ

Опции темы
Опции просмотра
Комбинированный вид Комбинированный вид

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 14:24. Часовой пояс GMT +4.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc. Перевод: zCarot