forum.wfido.ru  

Вернуться   forum.wfido.ru > Прочие эхи > RU.HUSKY

Ответ
 
Опции темы Опции просмотра
  #1  
Старый 21.10.2018, 13:32
Stas Mishchenkov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Stas Mishchenkov написал(а) к All в Oct 18 12:08:22 по местному времени:

Нi, All!

Что я опять не так делаю?

[/usr/src/packages/hpt]# make
gcc -Ih -I/usr/include -c -s -O3 -fomit-frame-pointer -fstrength-reduce -fPIC -Wall -DDO_PERL `perl -MExtUtils::Embed -e ccopts` -DUNIX src/perl.c
Can't locate ExtUtils/Embed.pm in @INC (you may need to install the ExtUtils::Embed module) (@INC contains: /usr/local/lib64/perl/5.22 /usr/local/share/perl/5.22 /usr/lib64/perl5 /usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5 /usr/lib/perl5/vendor_perl .).
BEGIN failed--compilation aborted.
src/perl.c:72:20: fatal error: EXTERN.h: Нет такого файла или каталога
compilation terminated.
make: * [perl.o] Ошибка 1

Брал вот эти исодники: http://download.huskyproject.org/sou...e-20170406.tgz

Нave nice nights.
Stas Mishchenkov.

--- GoldED+/W64-MSVC 1.1.5-b20150715
Ответить с цитированием
  #2  
Старый 21.10.2018, 15:22
Alexey Vissarionov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Alexey Vissarionov написал(а) к Stas Mishchenkov в Oct 18 14:14:14 по местному времени:

Доброго времени суток, Stas!
21 Oct 2018 12:08:22, ты -> All:

SM> Что я опять не так делаю?

SM> Can't locate ExtUtils/Embed.pm in @INC (you may need to install
SM> the ExtUtils::Embed module)
SM> [...]
SM> EXTERN.h: Нет такого файла или каталога

Я помню, что у тебя альт - поэтому:

gremlin@ws:~ > apf find ExtUtils/Embed.pm EXTERN.h
perl-devel

Добавь его в BuildRequires.


--
Alexey V. Vissarionov aka Gremlin from Kremlin
gremlin ПРИ gremlin ТЧК ru; +vii-cmiii-ccxxix-lxxix-xlii

... Хайло (сущ.): инструмент для руководства горными и земляными работами
--- /bin/vi
Ответить с цитированием
  #3  
Старый 21.10.2018, 17:01
Stas Mishchenkov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Stas Mishchenkov написал(а) к Alexey Vissarionov в Oct 18 15:42:02 по местному времени:

Нi, Alexey!

21 окт 18 14:14, Alexey Vissarionov -> Stas Mishchenkov:

SM>> Что я опять не так делаю?

SM>> Can't locate ExtUtils/Embed.pm in @INC (you may need to install
SM>> the ExtUtils::Embed module)
SM>> [...]
SM>> EXTERN.h: Нет такого файла или каталога

AV> Я помню, что у тебя альт - поэтому:

AV> gremlin@ws:~ > apf find ExtUtils/Embed.pm EXTERN.h
AV> perl-devel

AV> Добавь его в BuildRequires.

Не прокатило. Нет такой команды.

Нave nice nights.
Stas Mishchenkov.

--- GoldED+/W64-MSVC 1.1.5-b20150715
Ответить с цитированием
  #4  
Старый 21.10.2018, 17:21
Alexey Vissarionov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Alexey Vissarionov написал(а) к Stas Mishchenkov в Oct 18 16:10:00 по местному времени:

Доброго времени суток, Stas!
21 Oct 2018 15:42:02, ты -> мне:

SM>>> Can't locate ExtUtils/Embed.pm in @INC (you may need to install
SM>>> the ExtUtils::Embed module)
SM>>> [...]
SM>>> EXTERN.h: Нет такого файла или каталога
AV>> Я помню, что у тебя альт - поэтому:
AV>> gremlin@ws:~ > apf find ExtUtils/Embed.pm EXTERN.h
AV>> perl-devel
AV>> Добавь его в BuildRequires.
SM> Не прокатило. Нет такой команды.

Зато у меня есть. А тебе достаточно добавить в .spec строчку
BuildRequires: perl-devel


--
Alexey V. Vissarionov aka Gremlin from Kremlin
gremlin ПРИ gremlin ТЧК ru; +vii-cmiii-ccxxix-lxxix-xlii

... Лотерея (сущ.): форма налога на незнание теории вероятности
--- /bin/vi
Ответить с цитированием
  #5  
Старый 21.10.2018, 18:32
Stas Mishchenkov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Stas Mishchenkov написал(а) к Alexey Vissarionov в Oct 18 17:16:54 по местному времени:

Нi, Alexey!

21 окт 18 14:14, Alexey Vissarionov -> Stas Mishchenkov:

SM>> Что я опять не так делаю?

SM>> Can't locate ExtUtils/Embed.pm in @INC (you may need to install
SM>> the ExtUtils::Embed module)
SM>> [...]
SM>> EXTERN.h: Нет такого файла или каталога

AV> Я помню, что у тебя альт - поэтому:

AV> gremlin@ws:~ > apf find ExtUtils/Embed.pm EXTERN.h
AV> perl-devel

У меня сработало вот так:

# apt-cache search ExtUtils/Embed.pm
# apt-get install perl-devel

после чего все собралось и заработало, в том числе и перлхук.

Нave nice nights.
Stas Mishchenkov.

--- не откладывай пьянку на завтра, а секс на старость.
Ответить с цитированием
  #6  
Старый 22.10.2018, 10:42
Stas Mishchenkov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Stas Mishchenkov написал(а) к Alexey Vissarionov в Oct 18 08:58:20 по местному времени:

Нi, Alexey!

21 окт 18 16:10, Alexey Vissarionov -> Stas Mishchenkov:

SM>>>> Can't locate ExtUtils/Embed.pm in @INC (you may need to install
SM>>>> the ExtUtils::Embed module)
SM>>>> [...]
SM>>>> EXTERN.h: Нет такого файла или каталога
AV>>> Я помню, что у тебя альт - поэтому:
AV>>> gremlin@ws:~ > apf find ExtUtils/Embed.pm EXTERN.h
AV>>> perl-devel
AV>>> Добавь его в BuildRequires.
SM>> Не прокатило. Нет такой команды.

AV> Зато у меня есть. А тебе достаточно добавить в .spec строчку
AV> BuildRequires: perl-devel

И что с ним потом делать?

Нave nice nights.
Stas Mishchenkov.

--- GoldED+/W64-MSVC 1.1.5-b20150715
Ответить с цитированием
  #7  
Старый 28.10.2018, 21:22
Brother Rabbit
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Brother Rabbit написал(а) к All в Oct 18 20:11:16 по местному времени:

Нi, All!

Не собирается.

rpmbuild -ta hpt.tar.gz

/usr/bin/ld: cannot find -lperl

Чего ему не хватает?

Нave nice nights.
Brother Rabbit.

--- Мне бесполезно что-либо запрещать, я и так не собираюсь ничего делать.
Ответить с цитированием
  #8  
Старый 28.10.2018, 22:06
Alexey Vissarionov
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Alexey Vissarionov написал(а) к Brother Rabbit в Oct 18 20:48:00 по местному времени:

Доброго времени суток, Brother!
28 Oct 2018 20:11:16, ты -> All:

BR> Не собирается.
BR> rpmbuild -ta hpt.tar.gz
BR> /usr/bin/ld: cannot find -lperl
BR> Чего ему не хватает?

perl-devel или perl-devel-static


--
Alexey V. Vissarionov aka Gremlin from Kremlin
gremlin ПРИ gremlin ТЧК ru; +vii-cmiii-ccxxix-lxxix-xlii

... Овощ вам в помощь - в смысле, хрен с вами!
--- /bin/vi
Ответить с цитированием
  #9  
Старый 28.10.2018, 22:06
Rinat H. Sadretdinow
Guest
 
Сообщений: n/a
По умолчанию сборка НPT

Rinat H. Sadretdinow написал(а) к Brother Rabbit в Oct 18 20:53:54 по местному времени:

Нello Brother!

28 Oct 18 20:11, you wrote to All:

BR> rpmbuild -ta hpt.tar.gz
BR> /usr/bin/ld: cannot find -lperl
BR> Чего ему не хватает?

libperl.so он явно хочет.

`yum install perl-devel` спасёт отца русской демократии.

Bye!

--- GoldED+/LNX 1.1.5-b20170303
Ответить с цитированием
  #10  
Старый 28.10.2018, 22:32
Mikhail Stakhanov
Guest
 
Сообщений: n/a
По умолчанию Re: сборка НPT

Mikhail Stakhanov написал(а) к All в Oct 18 21:22:36 по местному времени:

Привет, All!

Ответ на сообщение Brother Rabbit (2:460/5858) к All, написанное 28 окт 18 в 20:11:


BR> rpmbuild -ta hpt.tar.gz

BR> /usr/bin/ld: cannot find -lperl

centos 7 x64
rpmbuild для hpt не берет .h файлы из /usr/lib64/perl5/CORE . Почему ?
скачен отсюда:
cvs -z3 -d:pserver:anonymous@a.cvs.sourceforge.net:/cvsroot/husky co -P hpt

С уважением - Mikhail
--- GoldED+/W32-MINGW 1.1.5-b20120519
Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Текущее время: 23:00. Часовой пояс GMT +4.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc. Перевод: zCarot